entrust IT Ltd - filterIT Service - Delivery Delayed on Some Messages – Incident details

filterIT Service - Delivery Delayed on Some Messages

Resolved
Degraded performance
Started over 1 year agoLasted about 9 hours

Affected

Email Filtering (filterIT)

Degraded performance from 12:13 PM to 8:59 PM

Updates
  • Resolved
    Resolved

    This incident was resolved by the earlier fix.

  • Update
    Update

    We have implemented a fix and are currently monitoring the result.

  • Monitoring
    Monitoring

    A workaround has been applied improve responsiveness, and work is advanced with a repair with the underlying issue.

  • Identified
    Identified

    We've identified the cause of the degraded performance.

  • Investigating
    Investigating
    We are currently investigating this incident.